Browse Source

Kompatible Abhängigkeiten hinzugefügt

master
Ulli Kehrle 1 month ago
parent
commit
3010237f05
  1. 8
      README.md
  2. 19
      requirements.txt

8
README.md

@ -24,6 +24,14 @@ Das [Dokumentations Repo](https://git.neo-layout.org/neo/dokumentation) herunter
git clone https://git.neo-layout.org/neo/dokumentation.git
```
Das Produktivsystem verwendet zur Zeit Version 6.1.4 von mkdocs-material. Eine kompatible Testumgebung kann man mit
```
python -m venv venv
. venv/bin/activate
pip installl -r requirements.txt
```
aufsetzen.
### Bauen
Den lokalen MkDocs Server im Dokumentations-Repository mit `mkdocs serve` starten. Die Dokumentation wird nun auf `http://localhost:8000` angezeigt und bei Änderungen automatisch aktuallisiert.

19
requirements.txt

@ -0,0 +1,19 @@
click==7.1.2
future==0.18.2
Jinja2==2.11.3
joblib==1.0.1
livereload==2.6.3
lunr==0.5.8
Markdown==3.3.4
MarkupSafe==1.1.1
mkdocs==1.1.2
mkdocs-material==6.1.4
mkdocs-material-extensions==1.0.1
nltk==3.6.2
Pygments==2.8.1
pymdown-extensions==8.1.1
PyYAML==5.4.1
regex==2021.4.4
six==1.15.0
tornado==6.1
tqdm==4.60.0
Loading…
Cancel
Save