#241 Probleme mit Ebene 4 in einer NX-Sitzung unter Windows

Closed
opened 10 years ago by neo523.20.slart · 0 comments

Umgebung: Auf einem Windows XP SP3 System verwende ich NX um mich mit einer virtuellen Maschine mit Ubuntu 10.04 zu verbinden. Ich verwende keine volle Desktop-Sitzung, sondern starte nur ein gnome-terminel. Auf dem Windows-System ist der kbdneo-Treiber installiert. Damit ich im gnome-terminal Neo nutzen kann, muss ich dort zusätzlich eingeben:
setxkbmap lv && xmodmap ~/neo_de.xmodmap && xset -r 51

Problem: Wenn ich in der NX-Sitzung (d.h. nur dort, in anderen Windows-Fenstern funktioniert alles) mittels der <>| - Taste Ebene-4-Funktionen wie Pfeil-, BildAuf/Ab-, Backspace-, Enter-Tastendrücke verwenden möchte, kommen in der Anwendung immer zwei Tastendrücke an, also z.B. bewegt sich der Cursor dann um zwei Zeichen nach links statt um eines. Seltsamerweise ist dies bei der Eingabe von z.B. ¡ oder ¿ nicht der Fall, obwohl die Zeichen auf der gleichen Ebene liegen.

Mir ist bewusst, dass das eine recht spezielle Umgebung und evtl. auch ein reines NX-Problem ist, daher rechne ich nicht mit einer hohen Priorisierung. Aber ich wollte es der Vollständigkeit halber mal melden.

Umgebung: Auf einem Windows XP SP3 System verwende ich NX um mich mit einer virtuellen Maschine mit Ubuntu 10.04 zu verbinden. Ich verwende keine volle Desktop-Sitzung, sondern starte nur ein gnome-terminel. Auf dem Windows-System ist der kbdneo-Treiber installiert. Damit ich im gnome-terminal Neo nutzen kann, muss ich dort zusätzlich eingeben: setxkbmap lv && xmodmap ~/neo_de.xmodmap && xset -r 51 Problem: Wenn ich in der NX-Sitzung (d.h. nur dort, in anderen Windows-Fenstern funktioniert alles) mittels der <>| - Taste Ebene-4-Funktionen wie Pfeil-, BildAuf/Ab-, Backspace-, Enter-Tastendrücke verwenden möchte, kommen in der Anwendung immer zwei Tastendrücke an, also z.B. bewegt sich der Cursor dann um zwei Zeichen nach links statt um eines. Seltsamerweise ist dies bei der Eingabe von z.B. ¡ oder ¿ nicht der Fall, obwohl die Zeichen auf der gleichen Ebene liegen. Mir ist bewusst, dass das eine recht spezielle Umgebung und evtl. auch ein reines NX-Problem ist, daher rechne ich nicht mit einer hohen Priorisierung. Aber ich wollte es der Vollständigkeit halber mal melden.
neo523.20.slart added the
Bug
label 10 years ago
qwertfisch closed this issue 4 months ago
qwertfisch added the
Treiber/Linux/xmodmap
label 4 months ago
qwertfisch added the
Treiber/Windows/kbdneo
label 4 months ago
Sign in to join this conversation.
Loading…
There is no content yet.