#278 Compatibility with Microsoft IME Japanese Input (Katakana, Hiragana)

クローズ
tom_19889年前に作成 · 11件のコメント
tom_19889年前 にコメント

Under the NEO-LAYOUT in combination with IME, the Japanese moras “DA, DI/JI, DU/ZU, DE, DO” (だ、ぢ、づ、で、ど) are not recognized. Instead, it looks like this: “」お” (for “do”, the o is recognized but the d is not)

Also, the Hepburn-Romanization of じ、ざ、ず、ぞ (zi/ji, ...) can only be typed with “z” whereas under the QWERTY-Layout, a “j” is also recognized.

Finally, in combination with a German Interface, the ü becomes a k and vice versa which does not happen with the QWERTY-Layout. So when typing a mora of the k-row (ka, ki,... ), the “ü” or the “y” (Qwerty) must be used which is quite annoying.

Under the NEO-LAYOUT in combination with IME, the Japanese moras "DA, DI/JI, DU/ZU, DE, DO" (だ、ぢ、づ、で、ど) are not recognized. Instead, it looks like this: "」お" (for "do", the o is recognized but the d is not) Also, the Hepburn-Romanization of じ、ざ、ず、ぞ (zi/ji, ...) can only be typed with "z" whereas under the QWERTY-Layout, a "j" is also recognized. Finally, in combination with a German Interface, the ü becomes a k and vice versa which does not happen with the QWERTY-Layout. So when typing a mora of the k-row (ka, ki,... ), the "ü" or the "y" (Qwerty) must be used which is quite annoying.
tom_1988 がラベル
Verbesserung
を追加 9年前
tom_1988 がラベル
Treiber/Windows/AHK
を追加 9年前
florian9年前 にコメント

Welcher Treiber wird für Neo verwendet? Der native Treiber (kbdneo2.dll) oder Neo-Vars?

Welcher Treiber wird für Neo verwendet? Der native Treiber (kbdneo2.dll) oder Neo-Vars?
tom_19889年前 にコメント
投稿者

Neo-Vars, aber das war mit der dll nicht anders soweit ich mich erinnern kann^^

Neo-Vars, aber das war mit der dll nicht anders soweit ich mich erinnern kann^^
tom_19889年前 にコメント
投稿者

Doch es war anders, mein Fehler; wenn ich über die Dll Neo verwende und auf IME umschalte, legt IME einfach wieder das QWERTY-Layout zugrunde, weil mit dem Umschalten NEO ja deaktiviert wird.

Doch es war anders, mein Fehler; wenn ich über die Dll Neo verwende und auf IME umschalte, legt IME einfach wieder das QWERTY-Layout zugrunde, weil mit dem Umschalten NEO ja deaktiviert wird.
florian9年前 にコメント

na dann ;) Works for kbdneo

na dann ;) Works for kbdneo
tom_19889年前 にコメント
投稿者

Naja, aber dann muss man ja wieder das alte Layout lernen, um mit allen Fingern schreiben zu können... das bringts ja auch nicht... ^^

Naja, aber dann muss man ja wieder das alte Layout lernen, um mit allen Fingern schreiben zu können... das bringts ja auch nicht... ^^
florian9年前 にコメント

Bei QWERTZ wird ja auch auf QWERTY umgestellt, insofern verhält sich kbdneo wie erwartet.

Autohotkey bekommt Layout-Wechsel nicht mit und bleibt daher aktiv (genau wie der AHK-Zusatztreiber von kbdneo). Beim Layout-Wechsel ist ein AHK-Treiber immer von Hand zu deaktivieren. Das ist eine bekannte Schwachstelle.

Die MS-IME-Treiber bringen ihren eigenen zugrunde liegend Treiber mit. Ein Wechsel entspicht daher auch einem Layout-Wechsel. Zumindest ein Teil der oben beschriebenen Effekte lassen sich darauf zurückführen, dass du den AHK nicht deaktiviert hast:

ü(neo2)=y(qwertz)=z(qwerty, durch IME aktiv)
Das z wandelt der AHK zu k um usw.

Kurz es funktioniert einfach nicht den AHK mit dem falschen Treiber zu verwenden.

Ich glaube daher, dass dieser Bug ein Invalid oder Wontfix verdient hat.

Bei QWERTZ wird ja auch auf QWERTY umgestellt, insofern verhält sich kbdneo wie erwartet. Autohotkey bekommt Layout-Wechsel nicht mit und bleibt daher aktiv (genau wie der AHK-Zusatztreiber von kbdneo). Beim Layout-Wechsel ist ein AHK-Treiber immer von Hand zu deaktivieren. Das ist eine bekannte Schwachstelle. Die MS-IME-Treiber bringen ihren eigenen zugrunde liegend Treiber mit. Ein Wechsel entspicht daher auch einem Layout-Wechsel. Zumindest ein Teil der oben beschriebenen Effekte lassen sich darauf zurückführen, dass du den AHK nicht deaktiviert hast: ü(neo2)=y(qwertz)=z(qwerty, durch IME aktiv) Das z wandelt der AHK zu k um usw. Kurz es funktioniert einfach nicht den AHK mit dem falschen Treiber zu verwenden. Ich glaube daher, dass dieser Bug ein Invalid oder Wontfix verdient hat.
tom_19889年前 にコメント
投稿者

Naja gut, dann muss man wohl einfach für die D-Reihe immer kurz Shift+Pause drücken, und das d dann mit dem QWERTY-Layout schreiben...^^ Die anderen Punkte sind ja nicht SO wichtig...

Naja gut, dann muss man wohl einfach für die D-Reihe immer kurz Shift+Pause drücken, und das d dann mit dem QWERTY-Layout schreiben...^^ Die anderen Punkte sind ja nicht SO wichtig...
anonymousbriactobey が担当者に指名 9年前
briactobey9年前 にコメント

Microsoft IME und neo konnten auch für mich keine zufriendenstellende Kombination bringen. Die einzige Lösung, die ich bei meinen Tests mal überlegt habe, war einfach einen anderen IME zu benutzen, in der der AHK- oder kbd-Input korrekt übernommen wird. Habe jedoch noch keine solche gefunden.

Microsoft IME und neo konnten auch für mich keine zufriendenstellende Kombination bringen. Die einzige Lösung, die ich bei meinen Tests mal überlegt habe, war einfach einen anderen IME zu benutzen, in der der AHK- oder kbd-Input korrekt übernommen wird. Habe jedoch noch keine solche gefunden.
anonymousflorian が担当から解除 9年前
briactobeyflorian が担当者に指名 9年前
florian9年前 にコメント

Nochmal der Wechsel zu einer IME stellt einen Layoutwechsel da, keine Kombination mit dem aktuellem Layout. Autohotkey muss dafür deaktiviert werden, da könnte man höchstens einen Feature-Request bei AHK stellen.

Natürlich wurde keine passende IME gefunden, es kann sie schlicht nicht geben (außer jemand schreibt sie extra für euch).

Habe ich den Wechsel zu „Assigned“ richtig verstanden, dass du dich damit beschäfftigen willst?

Nochmal der Wechsel zu einer IME stellt einen Layoutwechsel da, keine Kombination mit dem aktuellem Layout. Autohotkey muss dafür deaktiviert werden, da könnte man höchstens einen Feature-Request bei AHK stellen. Natürlich wurde keine passende IME gefunden, es kann sie schlicht nicht geben (außer jemand schreibt sie extra für euch). Habe ich den Wechsel zu „Assigned“ richtig verstanden, dass du dich damit beschäfftigen willst?
briactobey8年前 にコメント

(Das mit dem assigned war ein Versehen, da ich das System noch nicht ganz verstehe.)

Hab es geschafft mit einem Trick den Google IME für Japanisch mit NeoVars zum laufen zu bringen. Hierbei muss das deutsche Layout als Standardlayout eingestellt sein und die Layoutdatei des IME in der Registry geändert werden.
Dazu muss in der Registry unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\ nach dem entsprechenden Eintrag für den IME gesucht werden (bei mir E0200411 - je nach IME unterschiedlich) und darin der Wert “Layout File” zur deutschen dll-Datei geändert werden (kbdgr.dll). Nach Neustart sollte es dann mit NeoVars funktionieren, solange QWERTZ der Standard ist.

Könnte möglicherweise auch mit dem MS IME funktionieren bzw. mit kbdneo.dll als geändertes Layout.

Viel Spaß damit ^^.

(Jemand der sich auskennt kann vielleicht entscheiden dieses Ticket (als wontfix?) zu schließen.)

(Das mit dem assigned war ein Versehen, da ich das System noch nicht ganz verstehe.) Hab es geschafft mit einem Trick den Google IME für Japanisch mit NeoVars zum laufen zu bringen. Hierbei muss das deutsche Layout als Standardlayout eingestellt sein und die Layoutdatei des IME in der Registry geändert werden. Dazu muss in der Registry unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\ nach dem entsprechenden Eintrag für den IME gesucht werden (bei mir E0200411 - je nach IME unterschiedlich) und darin der Wert "Layout File" zur deutschen dll-Datei geändert werden (kbdgr.dll). Nach Neustart sollte es dann mit NeoVars funktionieren, solange QWERTZ der Standard ist. Könnte möglicherweise auch mit dem MS IME funktionieren bzw. mit kbdneo.dll als geändertes Layout. Viel Spaß damit ^^. (Jemand der sich auskennt kann vielleicht entscheiden dieses Ticket (als wontfix?) zu schließen.)
fabi6年前 にコメント

so ich hab neo (mit nativem treiber) mit der googe ime für japanisch unter windows zum laufen bekommen! :)

dafür hab ich die google ime hier: (http://www.google.co.jp/intl/ja/ime/) runtergeladen. die seite ist auf japanisch, aber das eigentliche programm auf englisch, also keine panik.

dann habe ich wie briactobey beschrieben hat die registry angepasst:
unter: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\E0200411 bei dem schlüssel “Layout File” dem wert zu “kbdneo2.dll” geändert.

nach einem neustart klappt alles :)

so ich hab neo (mit nativem treiber) mit der googe ime für japanisch unter windows zum laufen bekommen! :) dafür hab ich die google ime hier: (http://www.google.co.jp/intl/ja/ime/) runtergeladen. die seite ist auf japanisch, aber das eigentliche programm auf englisch, also keine panik. dann habe ich wie briactobey beschrieben hat die registry angepasst: unter: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\E0200411 bei dem schlüssel "Layout File" dem wert zu "kbdneo2.dll" geändert. nach einem neustart klappt alles :)
qwertfisch が課題をクローズ 5ヶ月前
サインインしてこの会話に参加。
読み込み中…
まだ内容がありません