#432 Mod4 Lock funktioniert nicht unter Ubuntu/Linux

Closed
opened 5 years ago by paul · 1 comments
paul commented 5 years ago

Hallo,
ich benutze neo2 unter Ubuntu14.04 (die schon vorhandene Version über grafische Einstellung, also per xkbmap), aber der Mod4-Lock (auslösbar durch gleichzeitiges Drücken von “<” und “AltGr”) funktioniert nicht, d.h. es passiert einfach nichts, danach bin ich wieder in Neo-Ebene 1.
Normales Mod4, sowohl mit dem linken als auch dem rechten Modifier funktioniert tadellos, ebenso das Shift-Lock.

Hab bereits das xkb-data package (oder so ähnlich) aus den Ubuntu-repos neu installiert, und danach manuell die neuste xkbmap vom neo-svn wie im Wiki beschrieben. Leider keine Veränderung.

Hat jemand eine Idee wie das zu beheben ist, oder dasselbe Problem?

PS: ist eine Laptop-Tastatur ohne Ziffernblock, falls das etwas ausmacht.

Hallo, ich benutze neo2 unter Ubuntu14.04 (die schon vorhandene Version über grafische Einstellung, also per xkbmap), aber der Mod4-Lock (auslösbar durch gleichzeitiges Drücken von "<" und "AltGr") funktioniert nicht, d.h. es passiert einfach nichts, danach bin ich wieder in Neo-Ebene 1. Normales Mod4, sowohl mit dem linken als auch dem rechten Modifier funktioniert tadellos, ebenso das Shift-Lock. Hab bereits das xkb-data package (oder so ähnlich) aus den Ubuntu-repos neu installiert, und danach manuell die neuste xkbmap vom neo-svn wie im Wiki beschrieben. Leider keine Veränderung. Hat jemand eine Idee wie das zu beheben ist, oder dasselbe Problem? PS: ist eine Laptop-Tastatur ohne Ziffernblock, falls das etwas ausmacht.
paul added the
Bug
label 5 years ago
paul added the
Treiber/Linux/xkbmap
label 5 years ago
Stephan commented 5 years ago

Upstream ist der Mod4-Lock momentan nicht implementiert wegen eines Bugs im X-Server (https://bugs.freedesktop.org/show_bug.cgi?id=27988).
Der Mod4-Lock wird scheinbar selten genug verwendet, dass sich seitdem niemand mehr darum gekümmert hat.

In der xkb-Version von der Neo-Seite funktioniert der Mod4-Lock jedoch, zumindest bei mir. Vielleicht hast du sie nicht richtig installiert? Zum probieren kannst du schauen, ob Änderungen an deinen installierten Dateien auch tatsächlich eine Wirkung haben (setxkbmap de neo -option nicht vergessen).

PS: Wenn der Mod4-Lock funktioniert, könnte es mit deiner Laptop-Tastatur trotzdem noch Komplikationen geben: siehe dann Ticket #274.

Upstream ist der Mod4-Lock momentan nicht implementiert wegen eines Bugs im X-Server (https://bugs.freedesktop.org/show_bug.cgi?id=27988). Der Mod4-Lock wird scheinbar selten genug verwendet, dass sich seitdem niemand mehr darum gekümmert hat. In der xkb-Version von der Neo-Seite funktioniert der Mod4-Lock jedoch, zumindest bei mir. Vielleicht hast du sie nicht richtig installiert? Zum probieren kannst du schauen, ob Änderungen an deinen installierten Dateien auch tatsächlich eine Wirkung haben (`setxkbmap de neo -option` nicht vergessen). PS: Wenn der Mod4-Lock funktioniert, könnte es mit deiner Laptop-Tastatur trotzdem noch Komplikationen geben: siehe dann Ticket #274.
qwertfisch closed this issue 4 months ago
Sign in to join this conversation.
Loading…
There is no content yet.