#511 Temporäres Wechseln zu Ebene 4 nicht möglich

Open
opened 2 years ago by basti.borchers · 1 comments

Hallo!
Ich habe den typischen Fehler, dass die 4.Ebene von neo nicht richtig funktioniert.
Konkret bedeutet das, ich kann zwar durch Drücken der “AltGr” + “<>|” Kombination auf die 4.Ebene locken und dann auch tatsächlich z.B. die Nummern tippen. Versuche ich das jedoch temporär umzuschalten durch alleiniges Drücken der “AltGr” oder “<>|” - Tasten, dann werden immer die Zeichen der 1.Ebene ausgegeben.

Dieses Problem tritt sowohl in meinem Terminal (kitty), als auch in firefox auf.

Mein System:

Arch Linux 64-Bit
Sway 0.15.2-2

Ich habe mir sehr genau die FAQs durchgelesen und natürlich den Fix für dieses Problem ausprobiert. Das bedeutet, ich habe die neueste xkbmap heruntergeladen und sie in das /usr/share/X11 entpackt. Das hat leider nicht geholfen.

Ich habe daraufhin sway im debug mode gestartet und festgestellt, dass ich bei den Versuchen in der 4. Ebene zu tippen, folgende Fehlermeldungen bekomme:

Error:            Key <HYPR> added to map for multiple modifiers
                  Using Mod2, ignoring Mod4.
Error:            Key <MDSW> added to map for multiple modifiers
                  Using Mod3, ignoring Mod5. 

Die habe ich gegoogelt, ich finde dazu allerdings immer nur entweder den Hinweis auf den Fix aus der FAQ, oder es wird behauptet, dass diese Fehlermeldungen schon immer aufgetreten sind und neo trotzdem funktioniert.

Ich bin mit meinem Latein am Ende, vielleicht hat jemand einen Tip für mich :)

Falls mehr logs / config dateien benötigt werden, einfach kurz sagen! Diese Thematik ist für mich relativ neu, da ich früher GNOME user war und da alles out-of-the-box funktioniert hat!

Hallo! Ich habe den typischen Fehler, dass die 4.Ebene von neo nicht richtig funktioniert. Konkret bedeutet das, ich kann zwar durch Drücken der "AltGr" + "<>|" Kombination auf die 4.Ebene locken und dann auch tatsächlich z.B. die Nummern tippen. Versuche ich das jedoch temporär umzuschalten durch alleiniges Drücken der "AltGr" oder "<>|" - Tasten, dann werden immer die Zeichen der 1.Ebene ausgegeben. Dieses Problem tritt sowohl in meinem Terminal (kitty), als auch in firefox auf. Mein System: Arch Linux 64-Bit Sway 0.15.2-2 Ich habe mir sehr genau die FAQs durchgelesen und natürlich den [Fix](wiki/Neo%20unter%20Linux%20einrichten/xkbmap) für dieses Problem ausprobiert. Das bedeutet, ich habe die neueste xkbmap heruntergeladen und sie in das /usr/share/X11 entpackt. Das hat leider nicht geholfen. Ich habe daraufhin sway im debug mode gestartet und festgestellt, dass ich bei den Versuchen in der 4. Ebene zu tippen, folgende Fehlermeldungen bekomme: ``` Error: Key <HYPR> added to map for multiple modifiers Using Mod2, ignoring Mod4. Error: Key <MDSW> added to map for multiple modifiers Using Mod3, ignoring Mod5. ``` Die habe ich gegoogelt, ich finde dazu allerdings immer nur entweder den Hinweis auf den Fix aus der FAQ, oder es wird behauptet, dass diese Fehlermeldungen schon immer aufgetreten sind und neo trotzdem funktioniert. Ich bin mit meinem Latein am Ende, vielleicht hat jemand einen Tip für mich :) Falls mehr logs / config dateien benötigt werden, einfach kurz sagen! Diese Thematik ist für mich relativ neu, da ich früher GNOME user war und da alles out-of-the-box funktioniert hat!
basti.borchers added the
Bug
label 2 years ago
Stephan commented 2 years ago

Probier mal die Belegung einmal direkt mit defaults zu aktivieren per setxkbmap de neo -option.

Nutzt du Sway mit Wayland oder über X11? Als ich das letzte mal Sway mit Wayland getestet hatte (ca 8 Monate her), gab es noch einige Probleme seitens Sway/xkbcommon.

Ja, die Fehlermeldungen sind bekannt, haben keinen Einfluss auf die Funktionalität und lassen sich wohl nur mit größeren Änderungen an fremden Code in xkeyboard-config beheben. Da die Tastaturbelegungen nicht wirklich eine Testsuite haben, würde man dabei leider leicht Gefahr laufen, anderen die Layouts kaputt zu machen.

Probier mal die Belegung einmal direkt mit defaults zu aktivieren per `setxkbmap de neo -option`. Nutzt du Sway mit Wayland oder über X11? Als ich das letzte mal Sway mit Wayland getestet hatte (ca 8 Monate her), gab es noch einige Probleme seitens Sway/xkbcommon. Ja, die Fehlermeldungen sind bekannt, haben keinen Einfluss auf die Funktionalität und lassen sich wohl nur mit größeren Änderungen an fremden Code in xkeyboard-config beheben. Da die Tastaturbelegungen nicht wirklich eine Testsuite haben, würde man dabei leider leicht Gefahr laufen, anderen die Layouts kaputt zu machen.
qwertfisch added the
Treiber/Linux/xkbmap
label 4 months ago
Sign in to join this conversation.
Loading…
There is no content yet.