#557 Alt Gr aktiviert Ebene 3 anstatt Ebene 4

Closed
opened 1 month ago by WhatDothLife · 5 comments

Seit gestern ist meine Alt Gr Taste umgemappt. Während sie davor wie gewohnt Ebene 4 aktiviert hat, wird nun Ebene 3 angesteuert. Wenn ich mir in Gnome meine Tastatur anzeigen lasse, sieht man es neben der Leertaste:
image Wie kann ich das beheben?

SYSTEM  type       gnu/linux
        config     x86_64-pc-linux-gnu
        shell      /bin/zsh
        uname      Linux 5.8.6-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:19:36 UTC 2020 x86_64
        path       (~/.local/bin /usr/local/bin /usr/local/sbin /usr/bin /usr/bin/site_perl /usr/bin/vendor_perl /usr/bin/core_perl /usr/lib/emacs/27.1/x86_64-pc-linux-gnu)
-localstatedir=/var --with-x-toolkit=gtk3 --with-xft --with-wide-int --with-modules --with-cairo --with-harfbuzz 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fno-plt' CPPFLAGS=-D_FORTIFY_SOURCE=2 LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now
        features   XPM JPEG TIFF GIF PNG RSVG CAIRO SOUND GPM DBUS GSETTINGS GLIB NOTIFY INOTIFY ACL GNUTLS LIBXML2 FREETYPE HARFBUZZ M17N_FLT LIBOTF ZLIB TOOLKIT_SCROLL_BARS GTK3 X11 XDBE XIM MODULES THREADS LIBSYSTEMD JSON PDUMPER LCMS2 GMP

Seit gestern ist meine Alt Gr Taste umgemappt. Während sie davor wie gewohnt Ebene 4 aktiviert hat, wird nun Ebene 3 angesteuert. Wenn ich mir in Gnome meine Tastatur anzeigen lasse, sieht man es neben der Leertaste: ![image](/attachments/0bf53841-01e1-4aab-b41d-f62e21b3afe5) Wie kann ich das beheben? <details> ``` SYSTEM type gnu/linux config x86_64-pc-linux-gnu shell /bin/zsh uname Linux 5.8.6-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:19:36 UTC 2020 x86_64 path (~/.local/bin /usr/local/bin /usr/local/sbin /usr/bin /usr/bin/site_perl /usr/bin/vendor_perl /usr/bin/core_perl /usr/lib/emacs/27.1/x86_64-pc-linux-gnu) -localstatedir=/var --with-x-toolkit=gtk3 --with-xft --with-wide-int --with-modules --with-cairo --with-harfbuzz 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fno-plt' CPPFLAGS=-D_FORTIFY_SOURCE=2 LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now features XPM JPEG TIFF GIF PNG RSVG CAIRO SOUND GPM DBUS GSETTINGS GLIB NOTIFY INOTIFY ACL GNUTLS LIBXML2 FREETYPE HARFBUZZ M17N_FLT LIBOTF ZLIB TOOLKIT_SCROLL_BARS GTK3 X11 XDBE XIM MODULES THREADS LIBSYSTEMD JSON PDUMPER LCMS2 GMP ``` </details>
qwertfisch commented 1 month ago
Owner

Hast Du etwas umgestellt?
Habe jetzt nur ein Cinnamon zur Verfügung, aber dort kann man bei den Tastaturbelegungen noch weitere Optionen setzen, die die Vorgaben überschreiben. Eine davon heißt „Taste zum Wechsel in die dritte Tastaturebene“. Wenn ich da „Rechte Alt-Taste“ aktiviere, entsteht das beschriebene Phänomen.

Das ist natürlich nur eine mögliche Fehlerquelle. Wenn das nicht hilft, kannst Du testweise mittels setxkbmap de neo -option das Layout temporär zurücksetzen. Sollte es dann wieder funktionieren, vermute ich eine unpassende Standardeinstellung für die Tastaturbelegung (ähnlich wie oben).

Hast Du etwas umgestellt? Habe jetzt nur ein Cinnamon zur Verfügung, aber dort kann man bei den Tastaturbelegungen noch weitere Optionen setzen, die die Vorgaben überschreiben. Eine davon heißt „Taste zum Wechsel in die dritte Tastaturebene“. Wenn ich da „Rechte Alt-Taste“ aktiviere, entsteht das beschriebene Phänomen. Das ist natürlich nur eine mögliche Fehlerquelle. Wenn das nicht hilft, kannst Du testweise mittels `setxkbmap de neo -option` das Layout temporär zurücksetzen. Sollte es dann wieder funktionieren, vermute ich eine unpassende Standardeinstellung für die Tastaturbelegung (ähnlich wie oben).
WhatDothLife commented 1 month ago
Poster

setxkbmap de neo -option hat mein Problem gelöst, vielen Dank! Ich kann mich nicht erinnern irgendwelche Änderungen bei der Tastatur-Konfiguration vorgenommen zu haben. Evtl. gab es zwischendrin ein Systemupdate... Soll ich den Command dann einfach in meine Shell Config schreiben, oder geht das einfacher zu lösen?

`setxkbmap de neo -option` hat mein Problem gelöst, vielen Dank! Ich kann mich nicht erinnern irgendwelche Änderungen bei der Tastatur-Konfiguration vorgenommen zu haben. Evtl. gab es zwischendrin ein Systemupdate... Soll ich den Command dann einfach in meine Shell Config schreiben, oder geht das einfacher zu lösen?
qwertfisch commented 1 month ago
Owner

Die kanonische Lösung ist eben über die Tastatur-Einstellungen in Gnome. Wenn dies nicht möglich ist oder das Layout nach Neuanmeldung wieder defekt ist, probier es mit dem setxkbmap in der Shellconfig.

Die kanonische Lösung ist eben über die Tastatur-Einstellungen in Gnome. Wenn dies nicht möglich ist oder das Layout nach Neuanmeldung wieder defekt ist, probier es mit dem setxkbmap in der Shellconfig.
hrnz commented 1 week ago
Owner

Gnome hat (natürlich ganz woanders in den Einstellungen) eine Option, eine zusätzliche
Taste zu Mod3 zu machen. Da sollte man nach Möglichkeit nicht eine der Mod4-Tasten auswählen.
a

Gnome hat (natürlich ganz woanders in den Einstellungen) eine Option, eine zusätzliche Taste zu Mod3 zu machen. Da sollte man nach Möglichkeit _nicht_ eine der Mod4-Tasten auswählen. ![a](https://mkdocs.neo.uber.space/Benutzerhandbuch/images/linux-gnome-5.png)
WhatDothLife commented 5 days ago
Poster

Genau das war es. Danke für eure Hilfe.

Genau das war es. Danke für eure Hilfe.
WhatDothLife closed this issue 5 days ago
Sign in to join this conversation.
Loading…
There is no content yet.