BoneVars: G und Q werden noch als Ö und Ä abgebildet #583

Closed
opened 7 months ago by justQ · 14 comments
justQ commented 7 months ago

Bin ganz frisch, aber ohne G und Q / @ wird es langfristig schwer werden... ;)
Hintergrund: Beide Rechner haben Windows 10 drauf. Beides Mal die gleiche Bone.exe vom 9/5/21 runtergeladen und installiert.
Auf meinem Rechner zu Hause klappt alles bestens. Auf der Arbeit werden mir mit der exakt gleichen bone.exe die NeoBone Tastenbelegung von g und q noch als ö und ä abgebildet. Alle anderen offenbar korrekt.
Die NeoBone Tastenbelegung für ö und ä liefern auch ö und ä. Mir fehlen also effektiv die beiden Buchstaben g und q inkl. @-Symbol.
Die Auswahl unten rechts in der Windows-Leiste von ”Bearbeiten” bleibt ergebnislos.
Neu laden habe ich auch schon durchgeführt.
Hoffe das ist überhaupt der richtige Ort so etwas anzusprechen. Per Suche bin ich in den bisherigen Issues nicht fündig geworden.

Bin ganz frisch, aber ohne G und Q / @ wird es langfristig schwer werden... ;) Hintergrund: Beide Rechner haben Windows 10 drauf. Beides Mal die gleiche Bone.exe vom 9/5/21 runtergeladen und installiert. Auf meinem Rechner zu Hause klappt alles bestens. Auf der Arbeit werden mir mit der exakt gleichen bone.exe die NeoBone Tastenbelegung von g und q noch als ö und ä abgebildet. Alle anderen offenbar korrekt. Die NeoBone Tastenbelegung für ö und ä liefern auch ö und ä. Mir fehlen also effektiv die beiden Buchstaben g und q inkl. @-Symbol. Die Auswahl unten rechts in der Windows-Leiste von ”Bearbeiten” bleibt ergebnislos. Neu laden habe ich auch schon durchgeführt. Hoffe das ist überhaupt der richtige Ort so etwas anzusprechen. Per Suche bin ich in den bisherigen Issues nicht fündig geworden.
qwertfisch self-assigned this 7 months ago
qwertfisch added the
Treiber/Windows/AHK
label 7 months ago
Poster

Danke @qwertfisch!

wie geht es jetzt weiter? Sry bin ein Neuling...

Danke @qwertfisch! wie geht es jetzt weiter? Sry bin ein Neuling...
Owner

Ich werde mir die Sache heute abend anschauen, und wenn ich den Fehler nachstellen kann, ist ein Bugfix meist nicht weit. Wenn ich den Fehler nicht sehe, müssen wir nochmal reden … Anscheinend hast du ja auch zwei vermeintlich gleiche Konfigurationen, und auf der einen geht es, auf der anderen nicht.

Ja, das ist der richtige Ort für Fehlermeldungen. Alternativ kannst du auch den Neo-Chat bemühen für direkten Support. Beides in Ordnung.

Ich werde mir die Sache heute abend anschauen, und wenn ich den Fehler nachstellen kann, ist ein Bugfix meist nicht weit. Wenn ich den Fehler nicht sehe, müssen wir nochmal reden … Anscheinend hast du ja auch zwei vermeintlich gleiche Konfigurationen, und auf der einen geht es, auf der anderen nicht. Ja, das ist der richtige Ort für Fehlermeldungen. Alternativ kannst du auch den [Neo-Chat](https://www.neo-layout.org/Beitragen/Community/#neo-chat) bemühen für direkten Support. Beides in Ordnung.

Vertauschte oder fehlende Buchstaben treten häufig auf, wenn das „native“ Layout (also das, was in den Windows-Einstellungen festgelegt ist) nicht stimmt. Steht das bei dir auf „QWERTZ - Deutsch (Deutschland)“? Und ist es das erste in der Auswahlliste (Win+Space)?

Vertauschte oder fehlende Buchstaben treten häufig auf, wenn das „native“ Layout (also das, was in den Windows-Einstellungen festgelegt ist) nicht stimmt. Steht das bei dir auf „QWERTZ - Deutsch (Deutschland)“? Und ist es das erste in der Auswahlliste (Win+Space)?
Poster

@qwertfisch:
Danke für die Rückmeldung. Ja, wg. Problemen mit dem Download hatte ich die bone.exe von meiner Cloud auf den Arbeits-PC geladen. ALso zumindest die ist völlig identisch…
@Rojetto:
Danke. Morgen Früh werde ich das überprüfen können. Melde mich.

@qwertfisch: Danke für die Rückmeldung. Ja, wg. Problemen mit dem Download hatte ich die bone.exe von meiner Cloud auf den Arbeits-PC geladen. ALso zumindest die ist völlig identisch… @Rojetto: Danke. Morgen Früh werde ich das überprüfen können. Melde mich.
Owner

Bei mir hat sich nichts ergeben, wie ich den Fehler nachstellen könnte. @justQ tritt der Fehler nur in bestimmten Programmen auf? Teste mal bitte mit Notepad.exe.

Bei mir hat sich nichts ergeben, wie ich den Fehler nachstellen könnte. @justQ tritt der Fehler nur in bestimmten Programmen auf? Teste mal bitte mit Notepad.exe.
Poster

Also, die Tastatur ist auf "QWERTZ Deutschland" eingestellt. Der PC startet allerdings, ohne dass das NumPad aktiviert ist. Ist das NumPad deaktiviert, dann erfolgt nach der Eingabe eines Buchstabens noch ein Tabulator.
Aktiviere ich das NumPad, kann ich alle Buchstaben mit Ausnahme von g & q wie beschrieben eingeben.
Das tritt auch in Notepad++ auf.

Eben hatte sich aber alles irgendwie verknotet und statt Eingaben, hat es nur noch Bildfenster ausgewählt und in verschiedenen Ansichten rumgespielt- als wenn ich normalerweise Alt + Pfeiltasten oder Steuerung + Pfeiltasten verwende.

Also, die Tastatur ist auf "QWERTZ Deutschland" eingestellt. Der PC startet allerdings, ohne dass das NumPad aktiviert ist. Ist das NumPad deaktiviert, dann erfolgt nach der Eingabe eines Buchstabens noch ein Tabulator. Aktiviere ich das NumPad, kann ich alle Buchstaben mit Ausnahme von g & q wie beschrieben eingeben. Das tritt auch in Notepad++ auf. Eben hatte sich aber alles irgendwie verknotet und statt Eingaben, hat es nur noch Bildfenster ausgewählt und in verschiedenen Ansichten rumgespielt- als wenn ich normalerweise Alt + Pfeiltasten oder Steuerung + Pfeiltasten verwende.
Poster

Version ist:
Neo 2.0 rcab903d-r5be0022 (bone.exe)

falls das hilft.

Version ist: Neo 2.0 rcab903d-r5be0022 (bone.exe) falls das hilft.
Owner

Der PC startet allerdings, ohne dass das NumPad aktiviert ist. Ist das NumPad deaktiviert, dann erfolgt nach der Eingabe eines Buchstabens noch ein Tabulator.

Das hört sich sehr merkwürdig an. Ob der PC mit aktiviertem Numlock startet, ist für BoneVars egal. Das Programm schaltet beim Start / Aktivieren automatisch den Numlock an, egal wie der Status vorher ist. Anschließend erzeugt die Numlock-Taste einen Tabulator.

Wenn BoneVars aktiv ist, kann man Numlock gar nicht mehr ausschalten. Daher klingt deine Beschreibung ungewöhnlich. Verwendest du eine Notebook-Tastatur mit Fn-Numlock-Taste? Falls ja, schließ mal bitte eine Standardtastatur an und teste dann.

Eben hatte sich aber alles irgendwie verknotet und statt Eingaben, hat es nur noch Bildfenster ausgewählt und in verschiedenen Ansichten rumgespielt- als wenn ich normalerweise Alt + Pfeiltasten oder Steuerung + Pfeiltasten verwende.

Hört sich an wie der Ebene4-Lock (vergleichbar mit Capslock).

> Der PC startet allerdings, ohne dass das NumPad aktiviert ist. Ist das NumPad deaktiviert, dann erfolgt nach der Eingabe eines Buchstabens noch ein Tabulator. Das hört sich sehr merkwürdig an. Ob der PC mit aktiviertem Numlock startet, ist für BoneVars egal. Das Programm schaltet beim Start / Aktivieren automatisch den Numlock an, egal wie der Status vorher ist. Anschließend erzeugt die Numlock-Taste einen Tabulator. Wenn BoneVars aktiv ist, kann man Numlock gar nicht mehr ausschalten. Daher klingt deine Beschreibung ungewöhnlich. Verwendest du eine Notebook-Tastatur mit Fn-Numlock-Taste? Falls ja, schließ mal bitte eine Standardtastatur an und teste dann. > Eben hatte sich aber alles irgendwie verknotet und statt Eingaben, hat es nur noch Bildfenster ausgewählt und in verschiedenen Ansichten rumgespielt- als wenn ich normalerweise Alt + Pfeiltasten oder Steuerung + Pfeiltasten verwende. Hört sich an wie der [Ebene4-Lock](https://neo-layout.org/Benutzerhandbuch/Einrasten/) (vergleichbar mit Capslock).
Poster

Ah, das ist interessant. Ich kann immmer noch den Numlock ein- und ausschalten, auch wenn die Bone.exe aktiviert ist.
Wenn der Numlock deaktiviert ist und die Lampe nicht leuchtet, dann passiert das mit dem Tabulator nach jeder Eingabe.

Nein, eine Tastatur ohne Fn-Möglichkeiten/Taste. Aber ich probiere mal eine andere Tastatur. Melde mich dann.

Ah, das ist interessant. Ich kann immmer noch den Numlock ein- und ausschalten, auch wenn die Bone.exe aktiviert ist. Wenn der Numlock deaktiviert ist und die Lampe nicht leuchtet, dann passiert das mit dem Tabulator nach jeder Eingabe. Nein, eine Tastatur ohne Fn-Möglichkeiten/Taste. Aber ich probiere mal eine andere Tastatur. Melde mich dann.
Poster

Andere Tastatur, selbe Situation. :/

Andere Tastatur, selbe Situation. :/
Owner

Komm mal in den Chat, sonst wird sich das vermutlich nicht zeitnah lösen lassen.

Komm mal [in den Chat](https://webchat.freenode.net/#neo), sonst wird sich das vermutlich nicht zeitnah lösen lassen.
Poster

Hey, sorry. Gestern war ich leider gesundheitlich raus. Bin immer noch nicht ganz fit...

Hey, sorry. Gestern war ich leider gesundheitlich raus. Bin immer noch nicht ganz fit...
Poster

Hi, so habe noch einmal ein paar Einstellungen probiert. Alle mit dem selben Ergebnis wie beschrieben. Offenbar liegt hier eine merkwürdige Verquickung vor, von emulierten qwerty mit ”dead acute” und remote oben drauf.

Da NEO2 vorinstalliert ist und auch über Remote funktioniert habe ich mich entschieden, damit weiter zu machen. Zwischen Bone und neo liegen ja nur μ in Puncto Effizienz verglichen mit qwertz.
Danke also soweit!

Hi, so habe noch einmal ein paar Einstellungen probiert. Alle mit dem selben Ergebnis wie beschrieben. Offenbar liegt hier eine merkwürdige Verquickung vor, von emulierten qwerty mit ”dead acute” und remote oben drauf. Da NEO2 vorinstalliert ist und auch über Remote funktioniert habe ich mich entschieden, damit weiter zu machen. Zwischen Bone und neo liegen ja nur μ in Puncto Effizienz verglichen mit qwertz. Danke also soweit!
Owner

Zusammengefasster Stand bisher, nach längerer Diskussion im Chat:

  • Der Arbeits-PC wird per Remote angesteuert.
  • Der Heim-PC startet ein linuxbasiertes Minimalsystem (Citrix?), bei dem das Basis-Tastaturlayout aus einer Liste auswählbar ist. Dort wird auch Neo aufgeführt, jedoch nicht Bone.
  • Verschiedene Tests mit qwerty oder (vermutlich) qwertz als Basislayout waren nicht erfolgreich.

Wir hätten noch schauen können, welche Scancodes / Virtual Keycodes tatsächlich beim Gastsystem ankommen und einen angepassten Treiber erstellen. Dies lasse ich als Option stehen für den nächsten Nutzer mit dieser Konstellation und schließe vorläufig das Issue.

Zusammengefasster Stand bisher, nach längerer Diskussion im Chat: - Der Arbeits-PC wird per Remote angesteuert. - Der Heim-PC startet ein linuxbasiertes Minimalsystem (Citrix?), bei dem das Basis-Tastaturlayout aus einer Liste auswählbar ist. Dort wird auch Neo aufgeführt, jedoch nicht Bone. - Verschiedene Tests mit qwerty oder (vermutlich) qwertz als Basislayout waren nicht erfolgreich. Wir hätten noch schauen können, welche Scancodes / Virtual Keycodes tatsächlich beim Gastsystem ankommen und einen angepassten Treiber erstellen. Dies lasse ich als Option stehen für den nächsten Nutzer mit dieser Konstellation und schließe vorläufig das Issue.
qwertfisch closed this issue 6 months ago
qwertfisch added the
Remote
label 6 months ago
Sign in to join this conversation.
Loading…
There is no content yet.